2 (out of 7) paired trackers won't start tracking (probably outdated firmware)

When I start SteamVR and turn on controllers and all trackers, 2 out of 7 trackers won’t start tracking. Theirs LEDs lit green and they are connected to SteamVR. Only the 2 specific trackers have this issue.

I can get them to work if I do this:

  1. start SteamVR and turn everything on
  2. pair the 2 trackers again (they already are)
  3. restart SteamVR
  4. turn everything on (they are still not tracking)
  5. turn the 2 trackers off with power button (holding several seconds)
  6. turn them on with the button (at this point one of the 2 starts tracking)
  7. restart the other one again with the button (usually after that step this one starts tracking too)

I have already tried:
-release and beta version of SteamVR
-connecting the 2 trackers to Vive 2.0 dongles
-connecting them to different dongles in SW7
-using different tracker roles in SteamVR
-using different USB controllers on MB both 2.0 and 3.2

After that I start searching in SteamVR System Report and find out that these two trackers have outdated firmware in comparison to others. Specifically Watchman Firmware, Watchman FPGA and VRC Version. There is also one working tracker with outdated Radio Version.

Not working trackers with outdated watchman and VRC:

Firmware:	1632556731 WMBUILD-W64$@wmbuild-w64 2021-09-25 FPGA 51(0.51/0/0) BL 0 VRC 1632556731 Radio 1632527453
Hardware Revision:	product 240 rev 0.1.9 lot 2000/0/0 0
Hardware Id:	0xf0000109
Watchman Firmware:	1632556731 / 0 (2021-09-25) 
Watchman FPGA:	51 / 0 (0.51) 
VRC Version:	1632556731 / 1632556731 (2021-09-25) 
Radio Version:	1632527453 / 1632527453 (2021-09-25) 
Dongle Version:	1635558315 / 0 (2021-10-30) 
Supported Buttons:	0
Connected Dongle:	42BE2A9B87-1YX Version: Unknown Version
Device Path:	/devices/lighthouse/LHR-CDBFF99D


Firmware:	1632556731 WMBUILD-W64$@wmbuild-w64 2021-09-25 FPGA 51(0.51/0/0) BL 0 VRC 1632556731 Radio 1632527453
Hardware Revision:	product 240 rev 0.1.9 lot 2000/0/0 0
Hardware Id:	0xf0000109
Watchman Firmware:	1632556731 / 0 (2021-09-25) 
Watchman FPGA:	51 / 0 (0.51) 
VRC Version:	1632556731 / 1632556731 (2021-09-25) 
Radio Version:	1632527453 / 1632527453 (2021-09-25) 
Dongle Version:	1635558315 / 0 (2021-10-30) 
Supported Buttons:	0
Connected Dongle:	411C023C66-3YX Version: Unknown Version
Device Path:	/devices/lighthouse/LHR-107DB810

The one with outdated Radio:

Firmware:	1637337510 WMBUILD-W64$@wmbuild-w64 2021-11-19 FPGA 538(2.26/7/2) BL 0 VRC 1637337510 Radio 1626824526
Hardware Revision:	product 241 rev 3.0.9 lot 2000/0/0 0
Hardware Id:	0xf1030009
Watchman Firmware:	1637337510 / 0 (2021-11-19) 
Watchman FPGA:	538 / 0 (2.26) 
VRC Version:	1637337510 / 0 (2021-11-19) 
Radio Version:	1626824526 / 0 (2021-07-21) 
Dongle Version:	1635558315 / 0 (2021-10-30) 
Supported Buttons:	0
Connected Dongle:	C8CF96B071-6YX Version: Unknown Version
Device Path:	/devices/lighthouse/LHR-B0B583FE

The other 4 trackers that are fine:

Firmware:	1637337510 WMBUILD-W64$@wmbuild-w64 2021-11-19 FPGA 538(2.26/7/2) BL 0 VRC 1637337510 Radio 1632527453
Hardware Revision:	product 240 rev 0.1.9 lot 2000/0/0 0
Hardware Id:	0xf0000109
Watchman Firmware:	1637337510 / 0 (2021-11-19) 
Watchman FPGA:	538 / 0 (2.26) 
VRC Version:	1637337510 / 1632556731 (2021-11-19) 
Radio Version:	1632527453 / 1632527453 (2021-09-25) 
Dongle Version:	1635558315 / 0 (2021-10-30) 
Supported Buttons:	0

The thing is that I already updated all of them when they arrived and now there is no available update for them in SteamVR.

3 Likes

Based on other post on this forum I also noticed that Hardware Id on most of my trackers is 0xf0000109 whitch looks like to be wrong and instead there should be 0xf1030009.

OK, after reading other forum posts I decided to try the batch script for fixing HWID and firmware on all of my trackers with result:

  1. all of the working ones now have updated HWID and firmware (which is good) except one that still have older Radio Version. They now works how they should.

  2. the two trackers that had issues now have updated HWID. Anyway the process bricked them in fast flashing red. Because of it I tried to manually install firmware from SteamVR folder (the firmware here is also outdated v1632556731) which didn’t help much. Now they sometimes start with fast flashing red light which can be fixed by resetting and connecting them to PC.
    Now Firmware, VRC Version, Watchman FPGA and Watchman Firmware are still outdated. The issue is still not fixed.

Also I can get them to work if I do this: is not actually helpful - from latest research I have result that it is more random and also have some correlation with if they are warmed up. No need to re-pair them or restart everything that much.

And here is SteamVR system report of the two trackes:

Device 3 - Sledovací zařízení Tundra Tracker Tundra Labs LHR-107DB810
Firmware:	1632556731 WMBUILD-W64$@wmbuild-w64 2021-09-25 FPGA 51(0.51/0/0) BL 0 VRC 1632556731 Radio 1632527453
Hardware Revision:	product 241 rev 3.0.9 lot 2000/0/0 0
Hardware Id:	0xf1030009
Watchman Firmware:	1632556731 / 0 (2021-09-25) 
Watchman FPGA:	51 / 0 (0.51) 
VRC Version:	1632556731 / 0 (2021-09-25) 
Radio Version:	1632527453 / 0 (2021-09-25) 
Dongle Version:	1635558315 / 0 (2021-10-30) 
Supported Buttons:	0
Connected Dongle:	411C023C66-3YX Version: Unknown Version
Device Path:	/devices/lighthouse/LHR-107DB810
Best Alias:	/user/elbow/right


Device 4 - Sledovací zařízení Tundra Tracker Tundra Labs LHR-CDBFF99D
Firmware:	1632556731 WMBUILD-W64$@wmbuild-w64 2021-09-25 FPGA 51(0.51/0/0) BL 1637337510
Hardware Revision:	product 241 rev 3.0.9 lot 2000/0/0 0
Hardware Id:	0xf1030009
Watchman Firmware:	1632556731 / 0 (2021-09-25) 
Watchman FPGA:	51 / 0 (0.51) 
VRC Version:	1632556731 / 0 (2021-09-25) 
Radio Version:	1632527453 / 0 (2021-09-25) 
Dongle Version:	1635558315 / 0 (2021-10-30) 
Supported Buttons:	0
Connected Dongle:	42BE2A9B87-1YX Version: Unknown Version
Device Path:	/devices/lighthouse/LHR-CDBFF99D
Best Alias:	/user/elbow/left

Because the trackers start with fast flashing red light (probably to bootloader) almost always not sometimes (if they are turned off for about 60 seconds they will next time start to bootloader), I tried the update script again. I also figured out how almost always restart the trackers so they will load to application. With that I confirmed that the script updated all firmware except Radio Version. Also this update fixed the original issue. So now they start tracking immediately and looks like they also report battery level correctly, with slow update rate though.

Anyway now there is the issue with the fast flashing red light. From this state I can start the trackers to application if I connect the tracker to a usb cable with power, hold the button for several seconds, release button, disconnect the usb cable, hold again the button, when the tracker turns off while still holding the button plug the usb cable in again.

Because it looks like the firmware version doesn’t matter, it can be caused by the new bootloader that I installed with the script on the first try or updated HWID.

Here is log from the script:

Do not unplug the device at any point!

Verifying device data, please wait...


-- Device status --

Device serial number is lhr-cdbff99d

Device HWID is 0xf1030009
This is the correct HWID for Tundra Tracker.

Device firmware version is v1637337510
This is the correct firmware version for Tundra Tracker.

Device bootloader version is v1637337510
This is a newer than expected bootloader version for Tundra Tracker, quit for safety!

Resetting device, please wait...

Device is now safe to unplug!
Press Enter to quit...

=========================================

Do not unplug the device at any point!

Verifying device data, please wait...


-- Device status --

Device serial number is lhr-107db810

Device HWID is 0xf1030009
This is the correct HWID for Tundra Tracker.

Device firmware version is v1637337510
This is the correct firmware version for Tundra Tracker.

Device bootloader version is v1637337510
This is a newer than expected bootloader version for Tundra Tracker, quit for safety!

Resetting device, please wait...

Device is now safe to unplug!
Press Enter to quit...

And again SteamVR system report:

Device 3 - Sledovací zařízení Tundra Tracker Tundra Labs LHR-CDBFF99D
Firmware:	1637337510 WMBUILD-W64$@wmbuild-w64 2021-11-19 FPGA 538(2.26/7/2) BL 0 VRC 1637337510 Radio 1632527453
Hardware Revision:	product 241 rev 3.0.9 lot 2000/0/0 0
Hardware Id:	0xf1030009
Watchman Firmware:	1637337510 / 0 (2021-11-19) 
Watchman FPGA:	538 / 0 (2.26) 
VRC Version:	1637337510 / 0 (2021-11-19) 
Radio Version:	1632527453 / 0 (2021-09-25) 
Dongle Version:	1635558315 / 0 (2021-10-30) 
Supported Buttons:	0
Connected Dongle:	42BE2A9B87-1YX Version: Unknown Version
Device Path:	/devices/lighthouse/LHR-CDBFF99D
Best Alias:	/user/elbow/left


Device 4 - Sledovací zařízení Tundra Tracker Tundra Labs LHR-107DB810
Firmware:	1637337510 WMBUILD-W64$@wmbuild-w64 2021-11-19 FPGA 538(2.26/7/2) BL 0 VRC 1637337510 Radio 1632527453
Hardware Revision:	product 241 rev 3.0.9 lot 2000/0/0 0
Hardware Id:	0xf1030009
Watchman Firmware:	1637337510 / 0 (2021-11-19) 
Watchman FPGA:	538 / 0 (2.26) 
VRC Version:	1637337510 / 0 (2021-11-19) 
Radio Version:	1632527453 / 0 (2021-09-25) 
Dongle Version:	1635558315 / 0 (2021-10-30) 
Supported Buttons:	0
Connected Dongle:	411C023C66-3YX Version: Unknown Version
Device Path:	/devices/lighthouse/LHR-107DB810
Best Alias:	/user/elbow/right

I have this issue already for more then a month without resolve.

Now I am 100% sure that the issue is based on temperature of the trackers. When they are off in room temperature 22°C they will not start correctly. If they are little bit warmed up by being on, charging or in warm place like PC AIO exhaust for a while (few minutes), then they will work without any issue.
Based on this behaviour I can guess that is more hardware issue then software.

@lgbeno
So, I am asking, should I go for RMA with these two trackers or will be there any other attempt to fix this remotely?