SW3 dongle: 1 watchman stuck in 'enumerating'

Good day,
I’ve sent a few e-mails to the support address, although I understand that mailbox is a bit backed up with messages, so I thought I would throw this in the forum as well, if anybody else has any idea.

When they first arrived on Jan 3, they worked well with no major issues. Unfortunately, eventually the SW3 dongle stopped syncing 3 tracked devices.

The SW3 pairs 2 devices, then SteamVR will no longer allow any more connected devices, as it says that all are connected.

Creating a system report, the USB hub shows that only 2 of 3 watchmen are detected on the dongle. The 3rd hub shows as ‘enumerating’ it seems, which is why it can’t connect a 3rd device.
As shown here in the report:

<USB>
    [HostController] USB xHCI Compliant Host Controller
    Manufacturer: Generic USB xHCI Host Controller, Provider: Microsoft, 10/13/2021, 10.0.19041.1320
        Root Hub
            [Port1]: Generic USB Hub (VID:0424 PID:2513)
                [Port1]: USB Input Device (VID:28DE PID:2102), Valve Corporation, Dongle McDongleface, 45B37531B8-2YX
                [Port2]: USB Input Device (VID:28DE PID:2102), Valve Corporation, Dongle McDongleface, 86B6614F98-3YX
                [Port3]: (Enumerating) 

I have tried connecting the SW3 to different USB ports on my computer, with and without the included extension cable, upgrading SteamVR to beta, unsyncing and resyncing all controllers + trackers, all to no avail.
Here is the SteamVR system report, and an image of the problem.

Any troubleshooting tips or assistance would be much appreciated!

1 Like

Hey there, maybe this can help!

Have you tried uninstalling the dongle from the device manager?
If not, for an easy way to find which device it is, as it isn’t clear to see in the device manager, you can use USBDeview.

The dongle is easy to find with said tool.
Open it up and search for entries with a serial number ending in “-1AB”, so for example “45B37531B8-2YX”.

There should be three of those.
Select all of them by holding “Ctrl” and clicking each entry.
Then right click and choose “Uninstall Selected Devices”.

image

After that, plug your dongle back in and see if the report now shows all three USB input devices. If it does try reconnecting all trackers.

Thank you! I previously removed them with device manager, though I figured there’s no loss in trying with this program.

The result was the same unfortunately. The only difference now is that the 3rd hub device doesn’t even show up in device manager anymore. I’m almost certain that the chip is just fried or just not working as intended.

If there’s a way to attempt flashing it, I’m open to all suggestions at this point.

Does USBDeview show three devices ending with “45B37531B8-2YX”, for example?

After removing it from device manager, it doesn’t show up at all. This was even before using USBDeview.
Under SteamVR, it does show as enumerating, though by all other references, the 3rd USB device doesn’t exist.

If it doesn’t show up at all anymore, it is defective. Flashing the firmware is impossible like this.
The only thing you can do is wait for support to answer, so the RMA process can begin.

1 Like

Aww, dang, I was hoping I could fix it myself haha.

Well, I appreciate the assistance! Now I just have to be patient with the team getting back to me.

1 Like