SW7 Drops Trackers - cannot reliably connect all seven trackers

Hi there,

After all the hassle with the distributor I finally received my x7 bundle today … and sadly I am running into issues, like others do.

I’ve connected my SW7 dongle to a dedicated USB 3.0 controller (Renesas/NEC - µPD720202) and placed it in a cradle like my old vive dongles with a line of sight to the play space (4 Base stations, Valve Index + 2 Controllers).
I managed to upgrade the Firmware for each tracker and pair all of them to the dongle.

Sadly, at least one tracker will just drop out every few minutes and show up in SteamVR as not being connected (gray tracker icon) or keep blinking in the SteamVR UI for forever. The trackers are rock stable and don’t jitter or do any other funky stuff if they are connected, but just disappear completely (whilst their status indicator LED is still green).

I managed to keep all seven trackers online for more than ten minutes by adding another (Vive) dongle - but still, another random tracker will just disappear after a few minutes.

A 3 Tundra tracker setup works perfectly on the SW7 (no jittering, no drift - the best tracking experience I had so far with any Lighthouse controllers) - things start to get weird once I start adding more.

Is there a solution yet for the issues with the SW7? They are not getting sold anymore it seems, so … is there something we can do besides being stuck with a partially working dongle?
Why does Tundra not sell the HTC Vive Dongles anymore? Is there a way to aquire Vive Dongles + Cradles? I wouldn’t have an issue connecting 4 or more Vive Dongles and one SW7 to make that setup happen (I have enough dedicated USB controllers and ports).

I tried to go through the basic troubleshooting steps, but to no avail. I also monitored the USB-Stack on Windows for any funky USB issues, but didn’t notice any except for standard stuff like the internal USB hub of the dongle declaring to be FS USB, but the dongles declaring to be HS USB devices.

By the way, I did not experience any heat issues with the SW7 standing in its cradle. It’s warm to the touch, but that’s it. What I did notice though, is that certain Tundra Trackers at least report more battery capacity loss than others (around a third more loss than others).

Is there something I can do to remediate this issue? It’s kinda frustrating having to wait for that long only to end up with a partially working setup.
Are the naked 30-somehting-$ cheapo dongles on Ebay any good for use with the Tundra Trackers?

I’d appreciate any help.

Thanks,

The SteamVR Watchman protocol used for the communication between the trackers and the dongle is very sensitive to heat. The hotter the dongle gets, the more your trackers will drop out. The fix for now is to get a better cooling solution for the SW7. I personally have mine on a USB extension draped over a floor fan, but I’ve seen other people strap the dongle in front of a PC fan powered via a phone charger.

Hi,
thanks for the reply.

As far as I know, there shouldn’t be any heat related issue if the radios run at their specified operational temperature range - which gets not exceeded. The source of the heat is the USB hub, though, and not the radios.

I cannot believe that the device has not been tested thoroughly during development, thus I think the root issue might be related to the manufacturing process. But I can only guess.

I would like to know whether there would be a proper (blanket) solution from Tundra Labs for people owning a SW7 - since they went EOL almost immediately.

Also another thing, at least of the seven trackers refuse to charge their batteries. I cloned the git repo with the associated HWID and firmware update tools and had to update the HWID and bootloader for each of the seven trackers. I hope that now they will start a proper charge cycle / report proper charge.

What is the policy on faulty kickstarter sets, @lgbeno ?
Is this something a firmware update will be able to solve (SW7 issues and tracker charging)?
Is the root cause for these issues already known?
Is getting a bunch of separate dongles (be it HTC Vive or some No-Name Ebay DIY stuff) like mentioned in my first post something that would work?

Is this something a firmware update will be able to solve (SW7 issues and tracker charging)?

The updates you did with the tool should have fixed the charging issues.

Is getting a bunch of separate dongles (be it HTC Vive or some No-Name Ebay DIY stuff) like mentioned in my first post something that would work?

You can, nothing holds you back, it will just be a wire mess.

Why does Tundra not sell the HTC Vive Dongles anymore?

Tundra never sold the HTC dongles. As their name suggests, they are made by HTC and only they sell them.

@Keigun , thanks for the reply.

I’ll keep an eye out and check whether it worked, thanks for confirming.

Of course, but I rather was asking about experience with non tundra dongles together with Tundra Trackers (HTC Vive 2, No-Name ones from Ebay and other sellers). If it wouldn’t work, that would be 200 USD down the drain :slight_smile:

They did sell single HTC Dongles back then. Together with HDKs and single chips to develop SteamVR Lighthouse trackable devices (Proof: HTC Vive Tracker USB Dongle — Tundra Labs).
It assumably was an (unterstandable) strategic decision to drop competitor’s products after developing own ones. I’d do the same. But as a company I’d also swallow my pride and deliver a known working dongle, no matter who made it.

I’ll see what’s on the market in terms of dongles that will not burn a huge hole into my wallet. A funky DIY solution/workaround or modding stuff is something I’d like to avoid - I’d rather throw money at someone to own a known working solution that works as advertised - I do have the skills, but I don’t have the time nor a stomach for tinkering after work. That’s why I’m asking whether buying different dongles would make a x7 Tundra Tracker setup finally work.

As I said, you can, nothing holds you back.

They did sell HTC Dongles back then. Together with HDKs and single chips to develop SteamVR Lighthous trackable devices. See:

Back then they just sold HTC dongles like any other online store, they were still made by HTC.
They still sell the HDKs they make and now their own dongles daughter boards, just via a different shop.

Also it has nothing to do with pride, back then the dongles were always on short because HTC didn’t deliver them fast enough, nor could they give proper estimates. Also the “deliver a known working dongle” is a harsh statement that just isn’t fair.
They are making their own products and the majority works. I can use my SW7 dongle without any issues, so can many other people. They aren’t perfect and have noticed that themselves, it takes time.
There can be defects or faults and they will correct those. Write them a email if you haven’t yet done so, then sit back and wait. It’s a rather small company with a huge amount of support requests, still ongoing production for replacements and the new orders while fixing what is wrong.
It hasn’t been the smoothest start but it is definitely not like they don’t care.

I’m sorry, but what I meant that this won’t answer the question whether it will work or not. Of course I “can”, I’m aware of that. But will it work? ^^

It certainly does not feel that way for me. I know that people with issues will more likely complain and thus the perception can sometimes be, “that everything is not working”. But judging by the numbers that were delivered (at least 620 SW7) and the complaints here, on Reddit and elsewhere the failure rate seems to be unusually high.

The issues have been acknowledged by Tundra Labs, yes. But what I miss is the clear communication on how they will move forward and what the issues and their root causes are. One can only speculate here on the forum about heat issues and try out stuff that might or might not work.

That’s the issue. I have waited over a year now to even receive the product.
I don’t know whether I’d be eligible to talk to the US support, since I don’t want to deal with the EU Distributor. Apparently, they still have no way to write back, since their E-Mails never reached me certain other users, which caused a bit of frustration and misunderstanding. I’d have to bother @Unbound_VR.XR to work as a proxy and probe them every few weeks to see if there has been a response - a practice I guess @Unbound_VR.XR and I aren’t keen on doing.

My point is - if there’s a way to work around the issues by other means (getting a different dongle) to get a configuration of hardware (dongles + trackers) that is “known to work” - I would like to know.

I will go through the support process, yes - but due to the circumstances within and outiside of the sphere of influence of Tundra Labs I’m perfectly aware of the fact that it will take a long time for the issues to be resolved. That’s to be expected.

That’s why I asked whether any other dongles are known to work with a x7 setup in the first place. If an intermediate solution means I’d have to buy different dongles, I’ll do it. If it means I’d have to buy a bunch of Vive Trackers in the meantime, I’ll do it.
The goal would be to have working solution while the support can take care of the issue. I wouldn’t care whether I’d have to wait another few months to resolve the issues then.

I just want to know what’s up. I’m not even 100% sure whether the SW7 is the culprit here.

BTW, I would like to clarify:
SW5 and SW7 are not being sold anymore due to the long leadtime for deliveries of the USB 7-port chip that we use. Its now beyond a year of wait-time for that chip. That is why we have switched to SW3 + SW4 which we can reliably source for chips.

Hmmmmm, I have a question here:

It doesn’t seem like a SW7 is the culprit here. The reason being that it looks like random trackers are dropping off… When your Tracker is paired to one of the SW7 ports, it will always stay paired to the same port. Therefore if it is always 1 or 2 of the same tracker having problems, then I think it could be the SW7 problem.

In your case, it does seem like most of the time, it changes from tracker to tracker, so I am guess it could be a USB-related issue…

One of the best ways to troubleshoot this would be to directly connect SW7 to one of the USB2.0 ports on your PC. (We highly recommend USB2.0)

If the SW7 plugging directly to the PC’s USB port solves your problem, then I think it is quite clear.

For the record, can you state your PC specs?
Motherboard and CPU that you’re using?

Yes, yes it will. The trackers are based on an open standard and work with all dongles which comply to that.

One can only speculate here on the forum about heat issues

Not really a issue though. The heat isn’t an issue if you don’t stuff the dongle into the Index or somewhere where heat can cook it. You can find my captured data here if you want to have a look at it or the whole thread.

Do check other possibilities first, like jasonleong said.

Hi @jasonleong ,

thanks for the reply.

Yes, it appears that this only happens with many trackers connected to the dongle. Currently I’m only using it in a setup with 3 Tundra trackers, as adding more increases the chance of dropouts which are minimal (once every few hours) with three trackers only and recover pretty fast, wheras a dropout in a x7 configuration is permanent or not doable.

It is interesting that you mention USB issues, since I would have guessed it is a radio transmission related issue.

I will try whether plugging the dongle into a USB 2.0 port will help. Could this be related to the well known USB 3.0 interference with 2.4 GHz (also Bluetooth) signals?

Currently, the dongle is connected via a 2 meter cable+cradle to a PCIe USB Controller card with one dedicated USB 3.0 controller for each port (Renesas/NEC - µPD720202).

PC:

AMD Ryzen 9 5950X
on Gigabyte X570 UD - F36 Bios (AGESA 1.2.0.5)
2x G.Skill F4-3600C16 (16GB) @ 1800Mhz (3600) RAM
Asus TUF RTX 3080 Gaming OC (Nvidia GeForce RTX 3080) @ PCIe 4.0 x16
--> StarTech USB 3.1 Gen 1 PCIe Controller Card (4Ports, 4 Controllers) PEXUSB3S44V

My USB setup looks as follows:

My Computer: XRDEV03 - Windows 10 Pro x64
|---Renesas USB 3.0 eXtensible-Hostcontroller – 1.0 (Microsoft)
|   \---USB-Root-Hub (USB 3.0)
|       |SS-[1-1]
|       |SS-[1-2]
|       |---[1-3]: Generischer USB 2.0 Hub
|       |   |HS-[1-3-1]
|       |   |HS-[1-3-2]
|       |   \---[1-3-3]: Generischer USB 2.1 Hub // Valve Index
|       |       |FS-[1-3-3-1]: USB-Verbundgerät - 2× HID
|       |       |FS-[1-3-3-2]: USB-Verbundgerät - HID, COM3
|       |       |FS-[1-3-3-3]: USB-Verbundgerät - HID, Audio
|       |       |HS-[1-3-3-4]
|       |       \HS-[1-3-3-5]: Hub Controller
|       \HS-[1-4]
|---AMD USB 3.10 eXtensible-Hostcontroller – 1.10 (Microsoft)
|   +---USB-Root-Hub (USB 3.0)
|---Renesas USB 3.0 eXtensible-Hostcontroller – 1.0 (Microsoft)
|   +---USB-Root-Hub (USB 3.0)
|---Renesas USB 3.0 eXtensible-Hostcontroller – 1.0 (Microsoft)
|   \---USB-Root-Hub (USB 3.0)
|       |SS-[4-1]
|       |SS-[4-2]
|       |---[4-3]: Generischer USB 2.0 Hub // SW7 Dongle
|       |   |FS-[4-3-1]: USB-Eingabegerät - HID
|       |   |FS-[4-3-2]: USB-Eingabegerät - HID
|       |   |FS-[4-3-3]: USB-Eingabegerät - HID
|       |   |FS-[4-3-4]: USB-Eingabegerät - HID
|       |   |FS-[4-3-5]: USB-Eingabegerät - HID
|       |   |FS-[4-3-6]: USB-Eingabegerät - HID
|       |   \FS-[4-3-7]: USB-Eingabegerät - 2× HID
|       \HS-[4-4]
|---AMD USB 3.10 eXtensible-Hostcontroller – 1.10 (Microsoft)
|   \---USB-Root-Hub (USB 3.0)
|       |LS-[5-1]: USB-Eingabegerät - Keyboard // Keyboard
|       |FS-[5-2]: USB-Verbundgerät - Mouse, Keyboard, 2× HID // Mouse
|       |HS-[5-3]
|       |FS-[5-4]: Generic Bluetooth Radio // Bluetooth Dongle
|       |SS-[5-5]
|       |SS-[5-6]
|       |SS-[5-7]
|       \SS-[5-8]
|---AMD USB 3.10 eXtensible-Hostcontroller – 1.10 (Microsoft)
|   \---USB-Root-Hub (USB 3.0)
|       |FS-[6-1]: USB-Verbundgerät - Audio, 2× HID // Headphones
|       |HS-[6-2]
|       |HS-[6-3]
|       |HS-[6-4]
|       |HS-[6-5]
|       |HS-[6-6]
|       |SS-[6-7]
|       |SS-[6-8]
|       |SS-[6-9]
|       \SS-[6-10]
\---Renesas USB 3.0 eXtensible-Hostcontroller – 1.0 (Microsoft)
    +---USB-Root-Hub (USB 3.0)
1 Like

So, I mentioned USB issues because you said that only 3 trackers are connected… So that would mean mostly only 3 of the ports on SW7 will be actively working. Thus, this is the reason I believe that it may not be radio congestion. If there are 12 or more trackers connected, then I think that there is a high chance of radio congestion.

Exactly. That’s why in our SW3/5/7 bundles, we always advise USB2.0 slots whenever and wherever possible.

BTW, nice PC specs you got there! Love your G.Skill memory, those are GOOOOD!
On a side note, I did have quite a bit of issues with the AMD chipset’s USB. I would really investigate the USB2.0 vs USB3.0 setup.

Let me know if it solves the problems. If not, share what you found out and let’s see how it goes.

3 Trackers is the working configuration. These are the configurations I tried out:

  • SW7 + 7x Tundra:
    All Trackers connect at first, but at least one drops out and will not track (blinking blue icon in SteamVR) or disconnect (grey icon in SteamVR). If I restart the affected tracker, it will work again, but a different tracker will drop out within minutes.

  • SW7 + 7x Tundra + 3x Vive 2018 (10 Trackers in total):
    Same as above for the Trackers on the SW7, but the Vive Trackers (with their own dongles) are not affected.

  • SW7 + 3x Tundra:
    Works well and very stable (no jitter, wobble, drifting) for many hours - no trackers disconnect, although one of the trackers might lose tracking every hour or so (for a few seconds) which is, in my opinion, within an expected and acceptable range.

Yes, especially the X570 boards had USB issues in the past (before AGESA 1.2.0.2) related to USB 2.0 connectivity, PCIe 4.0, USB power states, etc.

Thank you. I will definitely try using the USB 2.0 port tonight or tomorrow and check different configurations against it.

Just as a note because I also had problems with my gigabyte board, even after I updated my BIOS to the recent AGESA 1.2.0.5 version. The USB controllers would sometimes randomly drop out. I had the weird On/Off Charge software from gigabyte installed, after uninstalling it and reinstalling the recent chipset drivers that fault was gone. What sometimes still happens is the RGB device dropping out once my HMD is connected because of the higher power draw.

Interesting note. By the way, could you benefit from a dedicated USB controller card (with a dedicated power supply via SATA, etc) in this case?
The reason I got one for myself in the first place, was actually resource exhaustion issues (to many devices) back then (and also trying not to run into possible known issues with the X570).

A dedicated USB card, even just powered by the PCI-E slot is beneficial if you have a lot of devices. Although the x570 boards usually have enough controllers for it. As far as I know the internal USB 2.0 Headers use a separate controller per two port header. PCI covers with USB extensions like these to said headers might already be enough to spread the resource usage.

I would like to add: Adding USB controller card, does the same thing as drawing or over-drawing power from your mainboard and PSU. If you were like me (using a cheap power supply unit), I think you are going to have all sorts of weird USB issues. I had them too and it disappeared after i splurged for a 800W psu to power my computer. Let me know about the testing and how it goes after plugging into USB2.0 port. I’m interested to know!

1 Like

I hope they aren’t using a cheap low wattage PSU with a 3080. lol

Yes… I was using a cheap low wattage PSU with a 3070Ti. facepalm

You live and you learn c:

So, I now had a 3 hour session with all the seven trackers with its SW7 connected to a USB 2.0 port on the motherboard (instead of a USB 3 port on the USB controller card).

Everything went surprisingly well for a while, but after around 40 minutes, trackers started to randomly drop out again. First they recovered pretty fast (feet got stuck sometimes), but then one would tracker stop tracking (drift away or disappear), followed by at least another or two acting up at the same time (trackers weren’t occluded and covered by 4 base stations). For example the left elbow tracker would be gone, followed by one foot, hip or knee tracker (always one to three trackers at once acting up) - it’s cascading. Even the Valve Index itself stopped tracking for a split second during this session (grey screen), which really never happens. The Valve Index controllers never were affected by any drifting.

I then turned off all trackers except for three (hip, foot L + R) and the tracking was rock stable for the rest of the session (1h) again.

Before I quit the session, I created a system report to gather relevant logs.

While I am not an expert on interpreting SteamVR logs, there are a many lines regarding LHR-64E52171 (Tundra Tracker used for the Hip that usually works fine in a 3 tracker setup) that get spammed a lot:

Tue May 17 2022 01:48:49.640 - lighthouse: LHR-64E52171 C: Assertion failed:  Explicit right sync does not match pending frame
Tue May 17 2022 01:48:49.808 - lighthouse: LHR-64E52171 C: Unexpected backwards sync by 269.610ms S-1
Tue May 17 2022 01:48:49.808 - lighthouse: LHR-64E52171 C: Unexpected sample before sync by 262.237ms S-1
.
.
Tue May 17 2022 01:48:52.992 - lighthouse: LHR-64E52171 C: Unexpected centroid ordering error 109.787ms S-1
.
.
Tue May 17 2022 01:48:54.027 - lighthouse: LHR-64E52171 C: Resetting tracking: no optical samples for 2057ms
Tue May 17 2022 01:48:54.027 - lighthouse: LHR-64E52171 C: Dropped 15689 back-facing hits, 1 non-clustered hits during the previous tracking session

Any ideas?

Also quick question:

Is it normal, that the with 7th dongle on the SW7 - unlike the other 6 - there’s an additional HID (HID compatible phone)?


    =========================== USB Port7 ===========================

Connection Status        : 0x01 (Device is connected)
Port Chain               : 6-2-7

      ========================== Summary =========================
Vendor ID                : 0x28DE (Valve Corporation)
Product ID               : 0x2102
USB version              : 2.00 -> wrong, device is Full-Speed only
Port maximum Speed       : High-Speed
Device maximum Speed     : Full-Speed
Device Connection Speed  : Full-Speed
Self Powered             : yes
Demanded Current         : 0 mA
Used Endpoints           : 3

      ======================== USB Device ========================

        +++++++++++++++++ Device Information ++++++++++++++++++
Device Description       : USB Input Device
Device ID                : USB\VID_1395&PID_005D&MI_05\6&2FD5F5B8&1&0005
Hardware IDs             : USB\VID_1395&PID_005D&REV_0010&MI_05 USB\VID_1395&PID_005D&MI_05
Driver KeyName           : {745a17a0-74d3-11d0-b6fe-00a0c90f57da}\0012 (GUID_DEVCLASS_HIDCLASS)
Driver                   : \SystemRoot\System32\drivers\hidusb.sys (Version: 10.0.19041.868  Date: 2021-03-30)
Driver Inf               : C:\WINDOWS\inf\input.inf
Legacy BusType           : PNPBus
Class                    : HIDClass
Class GUID               : {745a17a0-74d3-11d0-b6fe-00a0c90f57da} (GUID_DEVCLASS_HIDCLASS)
Service                  : HidUsb
Enumerator               : USB
PDO                      : \Device\00000088
Location Info            : 000b.0000.0001.001.000.000.000.000.000
Location IDs             : PCIROOT(0)#PCI(0102)#PCI(0000)#PCI(0800)#PCI(0001)#USBROOT(0)#USB(1)#USBMI(5), ACPI(_SB_)#ACPI(PCI0)#ACPI(BXBR)#ACPI(BYUP)#ACPI(BYD8)#ACPI(XHC1)#ACPI(RHUB)#ACPI(PRT1)#USBMI(5)
Container ID             : {98363c1b-5075-531a-8285-d4a03fd4aa50}
Manufacturer Info        : (Standard system devices)
Capabilities             : 0x80 (SurpriseRemovalOK)
Status                   : 0x0180200A (DN_DRIVER_LOADED, DN_STARTED, DN_DISABLEABLE, DN_NT_ENUMERATOR, DN_NT_DRIVER)
Problem Code             : 0
HcDisableSelectiveSuspend: 0
EnableSelectiveSuspend   : 0
SelectiveSuspendEnabled  : 0
EnhancedPowerMgmtEnabled : 0
IdleInWorkingState       : 0
WakeFromSleepState       : 0
Power State              : D0 (supported: D0, D1, D2, D3, wake from D0, wake from D1, wake from D2)
 Child Device 1          : HID-compliant consumer control device
  Device Path            : \\?\HID#VID_1395&PID_005D&MI_05&Col01#7&5fca8aa&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030} (GUID_DEVINTERFACE_HID)
  Kernel Name            : \Device\0000008c
  Device ID              : HID\VID_1395&PID_005D&MI_05&COL01\7&5FCA8AA&0&0000
  Class                  : HIDClass
  Driver KeyName         : {745a17a0-74d3-11d0-b6fe-00a0c90f57da}\0013 (GUID_DEVCLASS_HIDCLASS)
 Child Device 2          : HID-compliant phone
  Device Path            : \\?\HID#VID_1395&PID_005D&MI_05&Col02#7&5fca8aa&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030} (GUID_DEVINTERFACE_HID)
  Kernel Name            : \Device\0000008d
  Device ID              : HID\VID_1395&PID_005D&MI_05&COL02\7&5FCA8AA&0&0001
  Class                  : HIDClass
  Driver KeyName         : {745a17a0-74d3-11d0-b6fe-00a0c90f57da}\0014 (GUID_DEVCLASS_HIDCLASS)
 Child Device 3          : HID-compliant vendor-defined device
  Device Path            : \\?\HID#VID_1395&PID_005D&MI_05&Col03#7&5fca8aa&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030} (GUID_DEVINTERFACE_HID)
  Kernel Name            : \Device\0000008e
  Device ID              : HID\VID_1395&PID_005D&MI_05&COL03\7&5FCA8AA&0&0002
  Class                  : HIDClass
  Driver KeyName         : {745a17a0-74d3-11d0-b6fe-00a0c90f57da}\0015 (GUID_DEVCLASS_HIDCLASS)

        +++++++++++++++++ Registry USB Flags +++++++++++++++++
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags\28DE21020100
 osvc                    : REG_BINARY 00 00
 NewInterfaceUsage       : REG_DWORD 00000000 (0)

        ---------------- Connection Information ---------------
Connection Index         : 0x07 (Port 7)
Connection Status        : 0x01 (DeviceConnected)
Current Config Value     : 0x01 (Configuration 1)
Device Address           : 0x03 (3)
Is Hub                   : 0x00 (no)
Device Bus Speed         : 0x01 (Full-Speed)
Number Of Open Pipes     : 0x02 (2 pipes to data endpoints)
Pipe[0]                  : EndpointID=1  Direction=IN   ScheduleOffset=0  Type=Interrupt
Pipe[1]                  : EndpointID=1  Direction=OUT  ScheduleOffset=0  Type=Interrupt
Data (HexDump)           : 07 00 00 00 12 01 00 02 00 00 00 40 DE 28 02 21   ...........@.(.!
                           00 01 01 02 03 01 01 01 00 03 00 02 00 00 00 01   ................
                           00 00 00 07 05 81 03 40 00 02 00 00 00 00 07 05   .......@........
                           01 03 40 00 10 00 00 00 00                        ..@......

        --------------- Connection Information V2 -------------
Connection Index         : 0x07 (7)
Length                   : 0x10 (16 bytes)
SupportedUsbProtocols    : 0x03
 Usb110                  : 1 (yes, port supports USB 1.1)
 Usb200                  : 1 (yes, port supports USB 2.0)
 Usb300                  : 0 (no, port not supports USB 3.0)
 ReservedMBZ             : 0x00
Flags                    : 0x00
 DevIsOpAtSsOrHigher     : 0 (Device is not operating at SuperSpeed or higher)
 DevIsSsCapOrHigher      : 0 (Device is not SuperSpeed capable or higher)
 DevIsOpAtSsPlusOrHigher : 0 (Device is not operating at SuperSpeedPlus or higher)
 DevIsSsPlusCapOrHigher  : 0 (Device is not SuperSpeedPlus capable or higher)
 ReservedMBZ             : 0x00
Data (HexDump)           : 07 00 00 00 10 00 00 00 03 00 00 00 00 00 00 00   ................

    ---------------------- Device Descriptor ----------------------
bLength                  : 0x12 (18 bytes)
bDescriptorType          : 0x01 (Device Descriptor)
bcdUSB                   : 0x200 (USB Version 2.00) -> wrong, device is Full-Speed only
bDeviceClass             : 0x00 (defined by the interface descriptors)
bDeviceSubClass          : 0x00
bDeviceProtocol          : 0x00
bMaxPacketSize0          : 0x40 (64 bytes)
idVendor                 : 0x28DE (Valve Corporation)
idProduct                : 0x2102
bcdDevice                : 0x0100
iManufacturer            : 0x01 (String Descriptor 1)
 Language 0x0409         : "Valve Corporation"
iProduct                 : 0x02 (String Descriptor 2)
 Language 0x0409         : "Dongle McDongleface"
iSerialNumber            : 0x03 (String Descriptor 3)
 Language 0x0409         : "46671C9E1C-4YX"
bNumConfigurations       : 0x01 (1 Configuration)
Data (HexDump)           : 12 01 00 02 00 00 00 40 DE 28 02 21 00 01 01 02   .......@.(.!....
                           03 01                                             ..

    ------------------ Configuration Descriptor -------------------
bLength                  : 0x09 (9 bytes)
bDescriptorType          : 0x02 (Configuration Descriptor)
wTotalLength             : 0x0029 (41 bytes)
bNumInterfaces           : 0x01 (1 Interface)
bConfigurationValue      : 0x01 (Configuration 1)
iConfiguration           : 0x04 (String Descriptor 4)
 Language 0x0409         : "Default configuration"
bmAttributes             : 0xC0
 D7: Reserved, set 1     : 0x01
 D6: Self Powered        : 0x01 (yes)
 D5: Remote Wakeup       : 0x00 (no)
 D4..0: Reserved, set 0  : 0x00
MaxPower                 : 0x00 (0 mA)
Data (HexDump)           : 09 02 29 00 01 01 04 C0 00 09 04 00 00 02 03 00   ..).............
                           00 00 09 21 11 01 00 01 22 BB 05 07 05 81 03 40   ...!...."......@
                           00 02 07 05 01 03 40 00 10                        ......@..

        ---------------- Interface Descriptor -----------------
bLength                  : 0x09 (9 bytes)
bDescriptorType          : 0x04 (Interface Descriptor)
bInterfaceNumber         : 0x00
bAlternateSetting        : 0x00
bNumEndpoints            : 0x02 (2 Endpoints)
bInterfaceClass          : 0x03 (HID - Human Interface Device)
bInterfaceSubClass       : 0x00 (None)
bInterfaceProtocol       : 0x00 (None)
iInterface               : 0x00 (No String Descriptor)
Data (HexDump)           : 09 04 00 00 02 03 00 00 00                        .........

        ------------------- HID Descriptor --------------------
bLength                  : 0x09 (9 bytes)
bDescriptorType          : 0x21 (HID Descriptor)
bcdHID                   : 0x0111 (HID Version 1.11)
bCountryCode             : 0x00 (00 = not localized)
bNumDescriptors          : 0x01
Data (HexDump)           : 09 21 11 01 00 01 22 BB 05                        .!...."..
Descriptor 1:
bDescriptorType          : 0x22 (Class=Report)
wDescriptorLength        : 0x05BB (1467 bytes)
Error reading descriptor : ERROR_INVALID_PARAMETER (due to a obscure limitation of the Win32 USB API, see UsbTreeView.txt)

        ----------------- Endpoint Descriptor -----------------
bLength                  : 0x07 (7 bytes)
bDescriptorType          : 0x05 (Endpoint Descriptor)
bEndpointAddress         : 0x81 (Direction=IN EndpointID=1)
bmAttributes             : 0x03 (TransferType=Interrupt)
wMaxPacketSize           : 0x0040 (64 bytes)
bInterval                : 0x02 (2 ms)
Data (HexDump)           : 07 05 81 03 40 00 02                              ....@..

        ----------------- Endpoint Descriptor -----------------
bLength                  : 0x07 (7 bytes)
bDescriptorType          : 0x05 (Endpoint Descriptor)
bEndpointAddress         : 0x01 (Direction=OUT EndpointID=1)
bmAttributes             : 0x03 (TransferType=Interrupt)
wMaxPacketSize           : 0x0040 (64 bytes)
bInterval                : 0x10 (16 ms)
Data (HexDump)           : 07 05 01 03 40 00 10                              ....@..

    ----------------- Device Qualifier Descriptor -----------------
Error                    : ERROR_GEN_FAILURE

      -------------------- String Descriptors -------------------
             ------ String Descriptor 0 ------
bLength                  : 0x04 (4 bytes)
bDescriptorType          : 0x03 (String Descriptor)
Language ID[0]           : 0x0409 (English - United States)
Data (HexDump)           : 04 03 09 04                                       ....
             ------ String Descriptor 1 ------
bLength                  : 0x24 (36 bytes)
bDescriptorType          : 0x03 (String Descriptor)
Language 0x0409          : "Valve Corporation"
Data (HexDump)           : 24 03 56 00 61 00 6C 00 76 00 65 00 20 00 43 00   $.V.a.l.v.e. .C.
                           6F 00 72 00 70 00 6F 00 72 00 61 00 74 00 69 00   o.r.p.o.r.a.t.i.
                           6F 00 6E 00                                       o.n.
             ------ String Descriptor 2 ------
bLength                  : 0x28 (40 bytes)
bDescriptorType          : 0x03 (String Descriptor)
Language 0x0409          : "Dongle McDongleface"
Data (HexDump)           : 28 03 44 00 6F 00 6E 00 67 00 6C 00 65 00 20 00   (.D.o.n.g.l.e. .
                           4D 00 63 00 44 00 6F 00 6E 00 67 00 6C 00 65 00   M.c.D.o.n.g.l.e.
                           66 00 61 00 63 00 65 00                           f.a.c.e.
             ------ String Descriptor 3 ------
bLength                  : 0x1E (30 bytes)
bDescriptorType          : 0x03 (String Descriptor)
Language 0x0409          : "46671C9E1C-4YX"
Data (HexDump)           : 1E 03 34 00 36 00 36 00 37 00 31 00 43 00 39 00   ..4.6.6.7.1.C.9.
                           45 00 31 00 43 00 2D 00 34 00 59 00 58 00         E.1.C.-.4.Y.X.
             ------ String Descriptor 4 ------
bLength                  : 0x2C (44 bytes)
bDescriptorType          : 0x03 (String Descriptor)
Language 0x0409          : "Default configuration"
Data (HexDump)           : 2C 03 44 00 65 00 66 00 61 00 75 00 6C 00 74 00   ,.D.e.f.a.u.l.t.
                           20 00 63 00 6F 00 6E 00 66 00 69 00 67 00 75 00    .c.o.n.f.i.g.u.
                           72 00 61 00 74 00 69 00 6F 00 6E 00               r.a.t.i.o.n.