Trackers drift, wobble, jitter, sometimes disappear entirely, can’t figure out what’s wrong

I’ve been testing the tundra trackers for a week (3 + SW3, firmware up to date, roles assigned). That there were issues was immediately apparent, but I’ve performed thorough testing and I can’t figure out where exactly the problem lies (there might be multiple). I can’t isolate any specific faulty component (unless it’s the SW3?) Maybe someone here can help me clear this up.

I have a current gen desktop PC (750w PSU, 3070ti, Ryzen 7 5800x), an HTC Vive, Index controllers and base stations v1.

Issues observed: Trackers wobble a little in incorrect directions when moving or even if they have been standing still for just a little while. If I haven’t been moving for a longer period of time they can disappear completely. Shortly after turning on or after they’ve been on for a more extended while they can jitter violently and disappear or look like they’re flying off into the distance. This never happens to all trackers at the same time. It seems to happen to interchangeable trackers on a per session basis. So far, if I’m wearing the trackers, the most stable tracker is always one of the feet (but I’ve swapped them). If the tracker has disappeared from the playspace, it won’t reappear until I’ve moved it quite a ways away from the position where it disappeared (after which I can go back to that position). Keep in mind these are not stable issues but they happen over time (reliably as long as I play long enough).

In the same playspace, the Index controllers and headset do not experience any tracking issues and are always rock stable and appearing where they’re supposed to be.

In addition to several hours of practical testing in VRChat, I’ve tested in “ideal” conditions by placing the trackers on a flat table right in the middle of my playspace, equidistant, with the index controllers beside them for reference and both of the base stations pointing directly at them. I’ve tried placing the trackers on their base and on their sides. I’ve moved around the table to ensure I wasn’t blocking anything. The Tundra trackers jittered, disappeared or were offset from their supposed positions while the Index controllers around them tracked properly.

I don’t know if it’s normal, but just passing my hand over the trackers while they’re on the table without touching them is enough to make them wobble a bit (the index controllers are fine).

I readjusted the aim of the base stations, redid room setup, used the steamvr button provided for the purpose to disable USB power management, none of which has helped (but the headset and controllers kept tracking properly). I’ve tripled checked there were no reflective surfaces in the room. My smartphone was removed. The windows were covered.

I’ve tried USB2 and USB3 ports for the dongle. I’ve tried the extension cable and a HTC weighted base. I’ve tried USB ports from my motherboard, from my computer case and through a USB extension card with dedicated power. I’ve tried placing the SW3 horizontally and vertically where applicable (including using the extension cable).

So. What exactly is going on here? Is there an issue with my computer or playspace that I can deal with myself in order to solve this problem? (If you’re an experienced full body use please try to remember if there’s anything and let me know, since it would be much easier than getting an RMA.) Or is the dongle broken? Or every tracker? Maybe everything at once? It does look like there might be more than one issue here…

1 Like


1 Like

Hey I was scrolling through and have seen a few threads like these, but you are the first to mention the HMD you’re using.

Something to try that’s worked for those of us in ‘mixed’ VR (lighthouse tracked devices with non-lighthouse tracked HMD): disconnect the Vive from the link box and plug it directly into the PC. You want to first turn off power saving features of the lighthouses in steamvr so they stay on when you exit vr.

The link box contains the Bluetooth dongle used to turn on/off the lighthouses, and for some reason it can cause some wild interference.

If that works for you, I’ll check with the others to see if they’re also on vives.

Very interesting suggestion. I’ll give it a try later today. If it works it won’t be a usable solution in the long term because without the link box the headset cable isn’t long enough for me to play properly in my playspace, but at least we’ll know more about the problem.

You might be able to just disable its Bluetooth in device manager (The name of the chipset is eluding me at the moment but it should be easy enough to find it by unplugging/plugging in the power to the link box while device manager is open) after seeing if it works. I’d try without the link box at all first though.

Let me know if that works! I had like three people come to me with a similar issue on normal vive dongles with vive as extra dongles just this week and it all turned out to be that Bluetooth, so it would be good to know :slight_smile:

1 Like

Wait is this The PumkinSpiceTruckNuts? Thanks for the help here. Recognize the name from reddit, it is one of my favorites!

1 Like

I’ve tried it during a 3hrs session just now. I would say the results were inconclusive as of yet.

I failed to get rid of the jitters immediately after startup. I started by disabling bluetooth in the SteamVR bluetooth settings, which normally should mean the linkbox’s bluetooth isn’t used. When that didn’t work, I plugged the Vive’s HDMI and USB directly to the motherboard. When that didn’t work, I unplugged the linkbox’s USB from the motherboard, leaving only its power input and output in use (unavoidable).

As I said earlier in the thread the instability happens intensely on startup and then resumes some time into the session. This session wasn’t very long, but throughout the session the trackers were fairly stable - it’s definitely possible that they were more stable than usual. On a couple of occasions the waist tracker disappeared from the playspace (in that way that’s hard to recover, took a minute or so each time). The feet were fine the whole time.

I made sure to also disable my bluetooth headphones and their transmitter, as well as my smartphone’s bluetooth during this test.

I’ll add more results when I play again.

Ah darn — it may partially be Bluetooth interference, but the results would be immediate and pretty obvious if that was the main issue. Is it mostly the waist tracker, and do you always use the same tracker on your waist? Have you used fbt - with vive trackers - in the past, without similar issues?

Haha yes that’s me! Never sure if I’m proud or ashamed of the user name I chose before accidentally stepping into a helper role XD

I have swapped a different tracker into the waist before. And yes, I feel like if there was an improvement it was in the slighter jitters and frequent instances of the trackers being offset from actual position (the trackers seemed to be more accurately positioned today; then again it’s still just one attempt).

I’ve only ever had access to one vive tracker but when I tried it in combination with two of the tundra trackers for the feet, it felt like a more stable session. I could try again with the vive tracker on the waist and bluetooth off and see how that goes. The vive tracker never got the startup period instability that the tundra trackers always get either. It does get unstable if there are occlusion problems but that seems normal.

Yeah the startup instability being there with vive trackers too was what I was curious about. Guess that rules that out too. Hmm.

Some shots in the dark: do you have rgb or hardware monitoring software running (try stopping them if so)? Have you run the performance monitor built into steamvr and noticed a lot of spikes? Are you using any plugins like ovras or input emulator? Have you tried turning off steamvr home?

These are all things that usually cause different symptoms than you’re seeing, but worth a shot! The issue looks like interference but it seems like you’ve eliminated most of that. It’s kind of something you can see with dongles too close to each other - which of course they’re really close to each other on the sw’s - but for example I have an sw7 (And a totally hacked together whole setup) and haven’t noticed anything that looks like interference.

Unfortunately there is no rgb or hardware monitoring software running normally (and I don’t remember running anything like that while steamvr is running). Steamvr home has been off for years since I noticed it worsened performance.

I do use OVRA so I can test turning that off. I need it for push to talk though (touch to talk using the index controller’s trackpad) since I have a coughing issue.

I will take a screenshot of the performance monitor next time and add it here.

What was the issue you had in mind for if the vive tracker was unstable on startup? I might as well test that too.

What I was “hoping” would be the case is that it’s jittery on startup with vive trackers as well so we would know if it’s something just going wrong with steamvr.

OVRAS doesn’t usually cause issues (especially if you’re not running steamvr home) but it’s just another step in process of elimination.

The last thing I’d try: pair the trackers to your vive and vive dongle, pair the index controllers to the sw3, and see if the trackers still act up, or if the index controllers start acting up.

OK, I tested the things you suggested. Note that all the tests took place shortly after (re)starting steamvr for obvious reasons (but there were no restarts between screenshots for the same test).

It seems misbehaving trackers are reported by SteamVR as not tracking, strictly while misbehaving.

A: 3PT control test with no bluetooth, no linkbox (those purple lines are very rare). No issues other than lack of AFK detection (I imagine due to the lack of linkbox).

B: Hybrid Tundra + Vive tracker test with no bluetooth, no linkbox, an SW3 and a Vive dongle. The Vive tracker was on the waist role. There was a little startup instability with the Vive tracker but it never disappeared from the playspace. The left foot Tundra tracker was very keen on flying off into the distance and then disappearing or resetting to position 0,0,0 and this persisted throughout the test. The right foot Tundra tracker was fairly stable.

Things went so bad with this test I was definitely convinced the linkbox is not the issue. After this test, I replugged the headset through the linkbox, enabled bluetooth and enabled bluetooth on my smartphone as well. My headphones and audio transmitter remained off, as that’s usually the case while using VR normally.

C: Regular setup with 3 tundra trackers paired through the SW3. The tracker I have on right foot remains fairly stable. Both the left foot and waist trackers are unstable. The left foot still flies off into the distance if I’m not moving it vigorously. The waist is more moderate in its insanity and only slides a few centimeters to the side, however it also disappears once in a while.

I notice that turning towards certain directions in the room may result in more instability for the unstable trackers, however it’s different for each of the two trackers. A problematic direction for the waist, for example, has direct line of sight to the dongles and a base station (!!!)

D: Swapped the antennas. I used the following procedure, let me know if this is wrong:

  1. Unplugged the headset and the Vive dongle and started steamvr. Started each index controller and paired it, which necessarily means they had to pair through the SW3.
  2. Unplugged the SW3 and plugged the headset, restarted steamvr using the restart headset option. Paired the two foot trackers, so they necessarily had to pair through the headset.
  3. Plugged the Vive dongle and then paired the waist tundra tracker. Plugged the SW3 and turned the index controllers back on.

There were no differences in behavior between test C and this one. If I successfully paired the trackers to the “wrong” antennas then this means the SW3 is functioning perfectly, since the index controllers were tracking perfectly. Something I tried involved placing the index controllers coplanar with the waist tracker and then waiting for the waist tracker to disappear from the playspace. The index controllers remained stable.

E: Same as D, but SteamVR was restarted without OVR Advanced Settings. It did not help!

Something interesting (still requires further observation though): While all tundra trackers begin by reporting an empty battery on the playspace model, the more stable tracker eventually displays a full battery, but the misbehaving trackers don’t seem to do so. I’m not sure if this is because trackers will only display the battery if they have been tracking for a while (and so their loss of tracking prevents them from doing so) or if there’s a correlated firmware issue.

All three trackers were plugged and charging for several hours.

Final nail in the coffin for the defective SW3 hypothesis. I was able to cobble together a USB-C extension cord using the Vive weighted base, the Tundra extension cable and an Index controller charging cable and test each of the Tundra trackers in the playspace in wired mode (both the SW3 and the Vive dongle were unplugged, and the Index controllers had previously been re-paired to the headset).

All three of the trackers behaved in much the same way as in previous tests, despite being wired, with the tracker currently mounted on my right foot VR “shoe” being the most stable, the waist tracker randomly vanishing and the left foot moving wildly around. So this has nothing to do with communication and is either a defect in the trackers themselves (or their firmware) or a defect in the base stations, although the base stations are still, as always, functioning properly with the other devices.

At first I seemed to notice a correlation between contact between the BACKPLATE of the tracker and something else (such as my body) and instability, with the waist tracker becoming more unstable when it was actually in contact with my waist (only the back plate–nothing touching or obstructing any of the other surfaces of the tracker). However, when I tried unscrewing the tracker from the belt and holding it by the USB-C plug, it still eventually wobbled and vanished, so that test is not conclusive.

It’s interesting that I previously saw a change in which trackers were stable or unstable but right now all three trackers seem to retain the same degree of stability across sessions. When in the past I swapped the trackers to test if this was true, I also had to swap the backplates so the new waist candidate could be screwed into the waist belt (while the foot trackers use the default backplates so they can be threaded into shoelaces). I doubt there’s an issue specific to either type of backplate, since the currently malfunctioning trackers use both types of backplate. But I wonder if there’s something in the process of screwing, unscrewing or swapping the backplates that can cause this problem.

I’ve tried to run some tests without a backplate. I’m using the “waist” Tundra tracker of the previous posts. At this point I’m back to using wireless comms through the SW3.

When holding the tracker, I did so using the center of the top handle, which is colored blue here: Hardware Specifications - Tundra Tracker User Manual

I got some interesting results. When I’m holding the tracker by the handle and away from everything else it wobbles just a bit. When I get the back closer to certain surfaces, it wobbles more. For example, the back of my hand makes it wobble more. My abdomen (through my shirt!) makes it fly off into the distance, which is a huge problem for a waist tracker. My shirt should not be particularly warm or conductive. Is this a capacitance problem?

Warm or metallic surfaces do not necessarily seem to make the tracker go wild, but even placing it bottom down on my desk I get offsets of up to 5cm.

EDIT: I was looking at the logs and it would appear that, during the periods of instability (such as the period after starting up), the trackers disappear when they can only see one base station at a time (such as when my body is occluding just one of the base stations) and they fail to switch from one base station to the other.

Disappearing tracker is logged like this:

Fri Feb 11 2022 02:59:47.217 - lighthouse: LHR-D66DF2BE C: Resetting tracking: no optical samples for 2000ms
Fri Feb 11 2022 02:59:47.217 - lighthouse: LHR-D66DF2BE C: Dropped 44580 back-facing hits, 2 non-clustered hits during the previous tracking session

Tracker not reappearing when turned around is logged like this:

Fri Feb 11 2022 03:04:05.780 - lighthouse: LHR-D66DF2BE C: Trying to start tracking from base 68A7AABB: Not enough contiguous samples for a bootstrap pose
Fri Feb 11 2022 03:04:05.780 - lighthouse: LHR-D66DF2BE C: Trying to start tracking from base 7A782809: Samples didn't yield successful bootstrap pose

A reminder that the base stations are pointed accurately enough for the remaining tracked devices in my playspace never to disappear during normal usage (and I can’t see how they could possibly be more accurate).

This observation on the correlation between the logs and disappearing tundra trackers doesn’t seem to apply to the wobbling/offset positions of all trackers. Those do not log anything.

During this test the tracker was mounted to the belt and being held by the belt only.

Wow thanks for all this extensive testing! Hopefully this is good data for the official channels here too

It sounds like you’re narrowing it down to the trackers themselves. I’ve seen people have issues with the lighthouses seeming to want to work independently, with one working better than the other, but it’s been every device in those instances. I wonder if it’s just the nature of the arc of the index controllers means both will generally always be seen by both lighthouses. Could you see what happens if you purposefully hide the controllers from one lighthouse at a time?

I’m also going to do some testing tomorrow based on your testing. My trackers are generally up above my hands or out in the open on a table (I’ve been working on those Lucas open gloves) so they haven’t had a lot of use as body trackers yet and are usually in full view of both lighthouses.

I tried it just now. I held an index controller flush against my abdomen and turned to one of the base stations, keeping my body between the controller and the other base station. Then I turned around to the other base station, hiding the first base station. I did this a few times, raising and lowering the index controller a bit to test different heights. It never disappeared/lost tracking/went off position.

For reference, the base stations are mounted to walls on opposite corners of the room, roughly 2.10m above floor level. According to the logs they are 3.56m apart from each other.

Very, very interesting. Hopefully I can get my space cleared tonight to do some good tests as well.

I just remembered of some flyaway/disappearing issues I was having when I first got index controllers. First time ended up being usb 3.0 interference, got that sorted, and it started happening again randomly. Finally narrowed it down to when I was playing in socks on the rug in dry weather. So, capacitance issue I guess. Stranger thing was that it did not happen when using with a native lighthouse setup and also did not happen with regular vive controllers… even though I was using the same external dongles both with index and with WMR, under the exact same conditions. But again you’re on all lighthouse tracking too so… well I guess I’ll see what my own testing does XD

Are there any news??